您的位置:首页 > 其它

poj_3273 Monthly Expense(二分穷举)

2016-12-04 23:01 429 查看
Monthly Expense

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23610 Accepted: 9197
Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤
moneyi ≤ 10,000) that he will need to spend each day over the next
N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤
M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and
M

Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the
ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400

Sample Output
500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a
larger minimum monthly limit.

二分求最大化最小值,二分区间为 花费最大的一天 到 所有天数花费的和。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define FOP2 freopen("data1.txt","w",stdout)
#define inf 0x3f3f3f3f
#define maxn 100010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int n, m;
int a[maxn];

bool judge(int mid)
{
int cot = 1, sum = 0;
for(int i = 1; i <= n; i++)
{
if(sum+a[i] <= mid) sum += a[i];
else sum = a[i], cot++;
}
return cot <= m;
}

int main()
{
while(~scanf("%d%d", &n, &m))
{
for(int i = 1; i <= n; i++) scanf("%d", &a[i]);

int l = 0, r = 0, mid;

for(int i = 1; i <= n; i++)
{
l = max(l, a[i]);
r += a[i];
}

while(l <= r)
{
mid = l + r >> 1;
if(judge(mid)) r = mid-1;
else l = mid+1;
}

printf("%d\n", mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: