您的位置:首页 > 其它

Mobile phones POJ1195(二维树状数组模板题)

2016-12-04 15:00 423 查看
Mobile phones

Time Limit: 5000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu
Submit Status

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered
from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number
of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists
of one instruction integer and a number of parameter integers according to the following table. 



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 

Cell value V at any time: 0 <= V <= 32767 

Update amount: -32768 <= A <= 32767 

No of instructions in input: 3 <= U <= 60002 

Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing
a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3


Sample Output

3
4


题目分析:这是一道二位树状数组模板题。由于是二维的,我们要求的范围是X1--X2&&Y1--Y2之间的范围。不能直接在getsum函数里面相减,详见代码;

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxx=1030;
int n;
int c[maxx][maxx];
int lowbit(int x)
{
return x&-x;
}

void addnum(int x,int y,int d)
{
for(int i=x;i<=n;i+=lowbit(i))
for(int j=y;j<=n;j+=lowbit(j))
{
if(c[i][j]+d>=0)
c[i][j]+=d;
else c[i][j]=0;

}
}

int getsum(int x2,int y2)
{
int res=0;
for(int i=x2;i>0;i-=lowbit(i))
{
for(int j=y2;j>0;j-=lowbit(j))
{
res+=c[i][j];
}
}
return res;
}

int main(){
int fir,x,y,a,b;
ios_base::sync_with_stdio(false);
while(cin>>fir)
{
if(fir==3)break;
else if(fir==0)cin>>n;
else if(fir==1)
{
cin>>x>>y>>a;
addnum(x+1,y+1,a);
}
else if(fir==2)
{
cin>>a>>b>>x>>y;
cout<<getsum(x+1,y+1)-getsum(x+1,b)-getsum(a,y+1)+getsum(a,b)<<endl;//可以画图理解一下,先减去两个旁边的区间,然后加上重复减掉的部分
}
}
return 0;}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  树状数组 poj