您的位置:首页 > 其它

HDU 1040 As Easy As A+B 水题

2016-12-03 17:21 351 查看


As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 58496    Accepted Submission(s): 25030


Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

 

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in
the same line. 

It is guarantied that all integers are in the range of 32-int.

 

Output

For each case, print the sorting result, and one line one case.

 

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

 

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9

 

Author

lcy

 

Recommend

We have carefully selected several similar problems for you:  1096 1004 1093 1089 1092 

 
水题,就是排一下序,我直接调用的c++里面的sort函数,进行快排
ac代码
#include <stdio.h>
#include <iostream>
#include <algorithm>

using namespace std;
int main()
{
int i,num,n,a[1005];

scanf("%d",&num);
while(num--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
for(i=0;i<n;i++)
{
if(i==0)
printf("%d",a[i]);
else
printf(" %d",a[i]);
}
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: