您的位置:首页 > 其它

poj 1002 487-3279

2016-12-03 00:43 176 查看
Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino’s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their “three tens” number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12

4873279

ITS-EASY

888-4567

3-10-10-10

888-GLOP

TUT-GLOP

967-11-11

310-GINO

F101010

888-1200

-4-8-7-3-2-7-9-

487-3279

Sample Output

310-1010 2

487-3279 4

888-4567 3

思路

刚开始用map < string,int > TLE n次,后来改用map< int, int >又TLE了n次.

把cin改scanf才好.

后来我测试了下如果加上一行

std::ios::sync_with_stdio(false);


cin也不会超时

还有

printf("%03d-%04d ",i->first/10000,i->first%10000);


03 04不能换成3 ,4.

第一种方法:用map

/*************************************************************************
> File Name: normal22e.cpp
> Author:gens_ukiy
> Mail:
> Created Time: 2016年12月02日 星期五 20时24分42秒
************************************************************************/

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<climits>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
int dire[4][2]={ {0,1},{1,0},{0,-1},{-1,0} };
int dire2[8][2]={{-1,-1},{-1,0},{-1,1},{ 0,-1},{ 0,1},{ 1,-1},{ 1,0},{ 1,1}};
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long
#define pi acos(-1)
using namespace std;
int main()
{
std::ios::sync_with_stdio(false);
#ifndef OnlineJudge
// freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
#endif

map<char,char> m;
string g="ABCDEFGHIJKLMNOPRSTUVWXY";
rep(i,0,23){
m[g[i]]=i/3+2+'0';
}

map<int,int> ans;
int T;
//scanf("%d",&T);
cin>>T;
char s[100];
while(T--){
//scanf("%s",s);
cin>>s;
int  num=0;
rep(i,0,strlen(s)-1){
if(isalpha(s[i])){
num = num*10 +m[s[i]]-'0';
}
else if(isdigit(s[i])){
num = num*10 +s[i]-'0';
}
}
ans[num]++;
}
int flag=0;
for(map<int,int>::iterator i=ans.begin();i!=ans.end();i++){
if(i->second>1){
flag=1;
printf("%03d-%04d ",i->first/10000,i->first%10000);
printf("%d\n",i->second);
}
}
if(!flag)
printf("No duplicates.\n");
return 0;
}


后来某次训练又碰到这道题….

用表驱动法

#include<iostream>
#include<stdio.h>
#include<map>
using namespace std;
#define NA 10000
const int mapping[] =
{
0, 1, 2, 3, 4, 5, 6, 7, 8, 9, // digit 0~9, ASCII 48~57
NA, NA, NA, NA, NA, NA, NA, // ASCII 58~64
2, 2, 2, // A~Y, Q = NA
3, 3, 3,
4, 4, 4,
5, 5, 5,
6, 6, 6,
7, NA, 7, 7,
8, 8, 8,
9, 9, 9
};
int main(){
std::ios_base::sync_with_stdio(false);
string str;
int n;
cin>>n;
map<int,int> m;
for(int k=0;k<n;k++){
cin>>str;
int num=0;
for(int i=0;i<str.length();i++){
int index=str[i]-'0';
int tmp=mapping[index];
if(index>=0&&index<=41&&tmp!=NA){
num=num*10+tmp;
}
}
m[num]++;
}
int flag=0;
for(map<int,int>::iterator i=m.begin();i!=m.end();i++){
if(i->second>1)
{
flag=1;
printf("%03d-%04d ",i->first/10000,i->first%10000);
printf("%d\n",i->second);
}
}
if(!flag)
printf("No duplicates.\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: