您的位置:首页 > 其它

【POJ 3630 Phone List】+ 字典树

2016-12-02 23:04 337 查看
Phone List

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 28373 Accepted: 8483

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26


In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2

3

911

97625999

91125426

5

113

12340

123440

12345

98346

Sample Output

NO

YES

判断给出的字符串中~是否存在该字符串是其他字符串的子串~~ 裸字典数~~

AC代码:(141ms)

#include<cstdio>
#include<cstring>
using namespace std;
const int MAX = 1e5 + 10;
char st[10100][10];
int word[MAX],ch[MAX][10],sz;
void init(){
sz = 1;
memset(ch[0],0,sizeof(ch[0]));
memset(word,0,sizeof(word));
}
void inse(char *s){
int nl = strlen(s),u = 0;
for(int i = 0 ; i < nl ;i++){
int c = s[i] - '0';
if(! ch[u][c]){
memset(ch[sz],0,sizeof(ch[sz])); // 最好初始化,防止被之前的数据影响到
ch[u][c] = sz++;
}
u = ch[u][c];
word[u]++;
}
}
int find(char *s){
int nl = strlen(s),u = 0;
for(int i = 0; i < nl; i++){
int c = s[i] - '0';
u = ch[u][c];
if(word[u] == 1) return 0; // 如果该字符串是其他字符串的子串,者该字符串必定不存在特有的字串
}
return 1;
}
int main()
{
int T,N;
scanf("%d",&T);
while(T--){
init();
scanf("%d",&N);
for(int i = 1 ; i <= N; i++){
scanf("%s",st[i]);
inse(st[i]);
}
int ok = 1;
for(int i = 1 ; i <= N; i++)
if(find(st[i])){ // 已找到
ok = 0;
break;
}
if(ok) printf("YES\n");
else printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj