您的位置:首页 > 编程语言 > Java开发

hdu 1130 How Many Trees? (java)

2016-12-02 19:05 555 查看
Problem Description

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log
n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?

Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

1

2

3

Sample Output

1

2

5

AC代码:
import java.math.BigInteger;
import java.util.Scanner;

public class Catalan{
// 卡特兰数
// h(n)=h(n-1)*(4*n-2)/(n+1);
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
BigInteger h[] = new BigInteger[1005];
h[0] = new BigInteger("1");
h[1] = new BigInteger("1");
BigInteger one = new BigInteger("1");
BigInteger four = new BigInteger("4");
BigInteger two = new BigInteger("2");
for (int i = 2; i < 1005; i++) {
String str = String.valueOf(i);
BigInteger n = new BigInteger(str);
h[i] = (n.multiply(four).subtract(two)).multiply(h[i - 1]).divide(
n.add(one));
}
while (in.hasNext()) {
int n = in.nextInt();
System.out.println(h
);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: