您的位置:首页 > 其它

hdu1880 魔咒词典 (hash)

2016-12-02 13:30 405 查看


魔咒词典

Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12845 Accepted Submission(s): 3099



Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky


Sample Output

light the wand
accio
what?
what?


Author

ZJU

Source

浙大计算机研究生复试上机考试-2008年

Recommend

We have carefully selected several similar problems for you: 1878 1877 1879 1881 1075

思路:裸BKDhash + 邻接表模拟链表。

代码如下:
#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MOD=1e5+10;
const int maxn=1e5+10;
struct Node
{
char x[25],y[85];
int next;
}Ledge[maxn],Redge[maxn];
bool flag;
int Lpre[maxn],Rpre[maxn],Ltot,Rtot;
void addedge(int Lhash,int Rhash,char* L,char *R)
{
strcpy(Ledge[Ltot].x,L);
strcpy(Ledge[Ltot].y,R);
Ledge[Ltot].next=Lpre[Lhash];
Lpre[Lhash]=Ltot;
Ltot++;
strcpy(Redge[Rtot].x,L);
strcpy(Redge[Rtot].y,R);
Redge[Rtot].next=Rpre[Rhash];
Rpre[Rhash]=Rtot;
Rtot++;
}
int getHash(char* str)
{
unsigned int seed = 131;
unsigned int hash = 0;
while (*str)
{
hash = hash * seed + *str++;
}
return (hash & 0x7fffffff) % MOD;
}
int query(char* str)
{
int strhash=getHash(str);
for(int i=Lpre[strhash];i!=-1;i=Ledge[i].next)
{
if(strcmp(str,Ledge[i].x)==0)
{
flag=false;
return i;
}
}
for(int i=Rpre[strhash];i!=-1;i=Redge[i].next)
{
if(strcmp(str,Redge[i].y)==0)
{
flag=true;
return i;
}
}
return -1;
}
void init()
{
for(int i=0;i<maxn;i++)
{
Lpre[i]=Rpre[i]=-1;
}
Ltot=Rtot=0;
}
int main()
{
init();
char s[120],L[25],R[85],que[85];
while(gets(s)!=NULL)
{
if(strcmp(s,"@END@")==0) break;
int len=strlen(s);
int Llen=0,Rlen=0;
bool flag=false;
for(int i=0;i<len;i++)
{
if(s[i]=='[') flag=true,i++;
else if(s[i]==']') flag=false,i+=2;
if(flag) L[Llen++]=s[i];
else R[Rlen++]=s[i];
}
L[Llen]=R[Rlen]='\0';
int Lhash=getHash(L),Rhash=getHash(R);
addedge(Lhash,Rhash,L,R);
}
int q;
scanf("%d",&q);
getchar();
while(q--)
{
gets(que);
if(que[0]=='[') strcpy(que,que+1),que[strlen(que)-1]='\0';
int ans=query(que);
if(ans==-1) printf("what?\n");
else if (flag) printf("%s\n",Redge[ans].x);
else printf("%s\n",Ledge[ans].y);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: