您的位置:首页 > 其它

sdut 二叉排序树

2016-12-02 02:35 176 查看


二叉排序树

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic Discuss


Problem Description

二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树


Input

开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)


Output

 


Example Input

2
123456789
987654321
432156789
0



Example Output

NO
NO

#include<iostream>
#include<string.h>
using namespace std;
char c[100],d[100];
typedef struct node
{
char data;
struct node *lchild,*rchild;
}node,*itree;
int o=0,e=0;
void insert(itree &t1,char key)
{
if(t1==NULL)
{
t1=new node;
t1->lchild=t1->rchild=NULL;
t1->data=key;
return ;
}
else
{
if(key<t1->data)
insert(t1->lchild,key);
else
insert(t1->rchild,key);
}
}
void pre_order(itree t)
{
if(t!=NULL)
{
c[o++]=t->data;
pre_order(t->lchild);
pre_order(t->rchild);
}
}
void post_order(itree t3)
{
if(t3!=NULL)
{
post_order(t3->lchild);
post_order(t3->rchild);
d[e++]=t3->data;
}
}
int main()
{
char a[100],b[100];
int n,len,i;
itree t1;
while(cin>>n)
{
if(n==0)
{
break;
}
t1=NULL;
cin>>a;
len=strlen(a);
for(i=0;i<len;i++)
{
insert(t1,a[i]);
}
pre_order(t1);
c[o]='\0';
post_order(t1);
d[e]='\0';
for(i=0;i<n;i++)
{
cin>>b;
if(strcmp(a,b)==0)
cout<<"YES"<<endl;
else if(strcmp(b,c)==0)
cout<<"YES"<<endl;
else if(strcmp(b,d)==0)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: