您的位置:首页 > 其它

Uva - 116 - Unidirectional TSP(多段图的最短路,动态规划)

2016-12-01 22:35 561 查看

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all
the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an 

 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere
in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last
rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.



The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different 

 matrices are shown below (the only difference is the numbers in the bottom row).



The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by 

 integers
where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second
row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more
spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that islexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10


Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19


思路:题目要求从左边到右边的最小权路径。输每列出行号。逆推求解。

1.设dp[i][j]为 从(i,j)位置出发,到最右边的最小权路径的权值。

2.状态转移方程:当前位置的最小权路径权值为,当前位置的权值+ 下一列的同一行,上一行和下一行的最小值。

3.边界为最后一行,从最后一行逆推到第一行。(注意第一行和最后一行的处理)

4.找出第一行的dp[][]最小值。

5.记得记录路径

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int d[11][101];
int nextpath[11][101]; //记录路径
int matrix[11][101];
int n,m,first;
int main(){
while(scanf("%d%d",&n,&m)!=EOF){
//读取数据
for(int i=0 ;i<n ;i++){
for(int j=0 ;j<m ;j++){
scanf("%d",&matrix[i][j]);
}
}

//逆推过程
for(int j=m-1 ;j>=0 ;j--){
for(int i=0 ;i<n ;i++){
if(j==(m-1))d[i][j] = matrix[i][j];
else{
int row[3] = {i, i-1 ,i+1};
if(i==0) row[1] = n-1;
if(i==(n-1)) row[2] = 0;
sort(row,row+3);
d[i][j] = 100000;
int temp = matrix[i][j];

//状态转换方程
for(int k=0 ;k<3 ;k++){

if(d[i][j]>(temp+d[row[k]][j+1])){
d[i][j] = (temp+d[row[k]][j+1]);
nextpath[i][j] = row[k];
}
}
}

}
}

//寻找最大值
int ans = 1000000000;
for(int i=0 ;i<n ;i++){
if(ans>d[i][0]){
ans = d[i][0];
first = i+1;
}
}

//输出路径
printf("%d",first);
for(int i=nextpath[first-1][0],j=1 ;j<m ; i=nextpath[i][j],j++){
printf(" %d",i+1);
}
printf("\n%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: