您的位置:首页 > 其它

Find them, Catch them poj 1703

2016-12-01 17:13 316 查看
Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42775 Accepted: 13164
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a]  

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.


有两个帮派,有两种操作 [b]D a b表示a 和 b不是一个帮派;
A a b 表示询问a b是否是一个帮派,若至此还不确定,输出“Not sure yet”。

代码:
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

int b[100005];
int a[100005];

int find(int x)
{
if ( b[x] == x )
return x;
int temp = b[x];
b[x] = find(b[x]);
a[x] = a[x]^a[temp];
return b[x];
}

void group(int x, int y)
{
int fx = find(x);
int fy = find(y);
b[fx] = fy;
a[fx] = !(a[x]^a[y]);
}

int main()
{
int n, m, i;
int T;
char ch[5];
int x, y;
scanf ( "%d", &T );
while ( T-- )
{
memset ( a, 0, sizeof(a) );
scanf ( "%d %d", &n, &m );
for ( i = 1;i <= n; i++ )
b[i] = i;
for ( i = 0;i < m; i++ )
{
scanf ( "%s %d %d", ch, &x, &y );
if ( ch[0] == 'A' )
{
if ( find(x) != find(y) )
{
printf ( "Not sure yet.\n" );
}
else
{
if ( a[x] == a[y] )
printf ( "In the same gang.\n" );
else
printf ( "In different gangs.\n" );
}
}
else
{
group(x, y);
}
}
}
}


代码菜鸟,如有错误, 请多包涵!!!
如有帮助记得支持我一下,谢谢!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: