您的位置:首页 > 其它

hdu 1241 Oil Deposits

2016-12-01 10:44 232 查看
Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either
*', representing the absence of oil, or
@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

@@*

@

@@*

1 8

@@**@*

5 5

**@

@@@

@*@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

思路

这道题dfs不需要回溯,如果当前符号为’@’,只需要往不同的方向遍历找’@’,直到找不到,为一块油田.当时不知道为啥老想着回溯,脑子一篇浆糊.

/*************************************************************************
> File Name: hdu1241.cpp
> Author:gens_ukiy
> Mail:
> Created Time: 2016年12月01日 星期四 09时35分36秒
************************************************************************/

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<climits>
#include<string>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
int dire[4][2]={ {0,1},{1,0},{0,-1},{-1,0} };
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long
#define pi acos(-1)
using namespace std;
#define maxn 105
char a[maxn][maxn];
int book[maxn][maxn];
int tot;
int n,m;
int dire2[8][2]={{-1,-1},{-1,0},{-1,1},
{ 0,-1},       { 0,1},
{ 1,-1},{ 1,0},{ 1,1}
};
void dfs(int x,int y){
book[x][y]=1;
rep(i,0,7){
int px = x+dire2[i][0];
int py = y+dire2[i][1];
if(a[px][py]=='@'&&book[px][py]==0&&px>=1&&px<=n&&py>=1&&py<=m){
dfs(px,py);
}
}
return;
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(scanf("%d %d",&n,&m)!=EOF){
if(m==0) break;
memset(book,0,sizeof(book));
tot=0;
rep(i,1,n)
rep(j,1,m)
cin>>a[i][j];
rep(i,1,n)
rep(j,1,m)
if(a[i][j]=='@'&&book[i][j]==0)
dfs(i,j),tot++;

printf("%d\n",tot);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: