您的位置:首页 > 其它

HDU 3746 字符串匹配(字符串的最小循环节问题)

2016-11-29 22:02 363 查看
Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial
spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful
decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with
colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost
pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that
is to say, adding to the middle is forbidden. 

CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000
).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3

aaa

abca

abcde

Sample Output

0

2
5

题意:给定一个字符串,问我们还需要添加几个字符可以构成一个由n个循环节组成的字符串(n>=2)

可知我们应该先求出字符串的最小循环节的长度:假设字符串的长度为len,那么最小的循环节就是length
= len-Next[len]

三种情况:

1:如aadrfghaa

2:如abcabcabc

3:如abcdabcdab

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
char array[100005];
int Next[100005];
int len;
void GetNext(){
int i=0,j=-1;
Next[0]=-1;
while(i<len){
while(j>-1&&array[i]!=array[j])
j=Next[j];
Next[++i]=++j;
}
return;
}
int main(){
int n;
int length;
cin>>n;
for(int i=0;i<n;i++){
scanf("%s",array);
len=strlen(array);
GetNext();
length=len-Next[len];
//printf("%d ",length);
if(length!=len&&len%length==0)//情况三
printf("%d\n",0);
else//情况一,二
printf("%d\n",length-Next[len]%length);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: