您的位置:首页 > 其它

bzoj1755 [Usaco2005 qua]Bank Interest

2016-11-29 09:08 435 查看

Description

Farmer John made a profit last year! He would like to invest it well but wonders how much money he will make. He knows the interest rate R (an integer between 0 and 20) that is compounded annually at his bank. He has an integer amount of money M in the range
100..1,000,000. He knows how many years Y (range: 0..400) he intends to invest the money in the bank. Help him learn how much money he will have in the future by compounding the interest for each year he saves. Print an integer answer without rounding. Answers
for the test data are guaranteed to fit into a signed 32 bit integer. 看了样例输入输出就知道怎么回事了..........

Input

* Line 1: Three space-separated integers: R, M, and Y

Output

* Line 1: A single integer that is the number of dollars FJ will have after Y years.

Sample Input

5 5000 4

INPUT DETAILS:

5% annual interest, 5000 money, 4 years

Sample Output

6077

OUTPUT DETAILS:

Year 1: 1.05 * 5000 = 5250

Year 2: 1.05 * 5250 = 5512.5

Year 3: 1.05 * 5512.50 = 5788.125

Year 4: 1.05 * 5788.125 = 6077.53125

The integer part of 6077.53125 is 6077.

这种题竟然都可以成为金组题23333333
题解:
直接快速幂
具体见代码
#include <stdio.h>
double kuai(double a,int b){
if(b==1) return a;
else if(b==0) return 1.0;
else{
double ans=kuai(a,b/2);
ans=ans*ans;
if(b&1) ans=ans*a;
return ans;
}
}
int main(){
int m;
double n,r;
scanf("%lf%lf%d",&r,&n,&m);
n=n*kuai((100.0+r)/100.0,m);
int z=n;
printf("%d",z);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: