您的位置:首页 > 大数据 > 人工智能

Waiting in Line

2016-11-28 16:30 337 查看

1014. Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait
in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At
08:00 in the morning, customer1 is served at window1
while customer2 is served at window2.
Customer3 will wait in front of window1
and customer4 will wait in front of window2.
Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5
enters the line in front of window1 since that line seems shorter now. Customer2
will leave at 08:02, customer4 at 08:06, customer3
at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number
of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after
17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output
08:07
08:06
08:10
17:00
Sorry

本题的思路逐一向队列中添加客户,如果队列全满则寻找最早完成的客户所在的队列,pop这个完成的客户,并将自己push到这个队列中,并记录自己的开始和结束时间。

需要注意的一点是17:00之前开始的客户能够processing,而不是17:00之前完成的客户。

#include <iostream>
#include <vector>
#include <queue>
#include <iomanip>

using namespace std;

int pop();
void push(int customer,int position);
int shortest();
void printTime(int min);

int n, m, k, q;
vector<int> T, Q, beginT, doneT;
vector<queue<int> > que;
int inside, capacity;
const int lastT = 540;

int main() {
cin >> n >> m >> k >> q;
capacity = n*m;
T.resize(k + 1);
for (int i = 1;i <= k;i++)
cin >> T[i];
Q.resize(q);
for (int i = 0;i < q;i++)
cin >> Q[i];

que.resize(n);
beginT.resize(k + 1);
doneT.resize(k + 1);
int position;
for (int i = 1;i <= k;i++) {
if (inside >= capacity)
position = pop();
else
position = shortest();
push(i, position);
}

for (int i = 0;i < q;i++) {
if (beginT[Q[i]] < lastT)
printTime(doneT[Q[i]]);
else
cout << "Sorry";
cout << endl;
}

system("pause");
return 0;
}

int pop() {
int min = 0;
for (int i = 1;i < n;i++) {
if (doneT[que[i].front()] < doneT[que[min].front()])
min = i;
}
que[min].pop();
inside--;
return min;
}
void push(int customer, int position) {
if (que[position].empty())
beginT[customer] = 0;
else
beginT[customer] = doneT[que[position].back()];
doneT[customer] = beginT[customer] + T[customer];
que[position].push(customer);
inside++;
}
int shortest() {
int min = 0;
for (int i = 1;i < n;i++) {
if (que[i].size() < que[min].size())
min = i;
}
return min;
}
void printTime(int min) {
int hour = 8 + min / 60;
int minute = min % 60;
cout << setw(2) << setfill('0') << hour << ':';
cout << setw(2) << setfill('0') << minute;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息