您的位置:首页 > 其它

POJ 3255 Roadblocks

2016-11-27 20:22 274 查看
Roadblocks

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13365 Accepted: 4695
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the
shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination)
is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if
two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output
450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
Source

USACO 2006 November Gold

到某个顶点v的次短距离要么是到其他某个顶点u的最短距离再加上u到v的边,要么是到其他某个顶点的次短路再加上u到v的边。

采用和DIjkstra算法一样的思路,每次先维护最短距离,再维护次短距离。

#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
#include <utility>
#include <cstdio>
using namespace std;
const int maxn =5000+10;
#define INF 0x3f3f3f3f
typedef pair<int,int> P;

int N,R;
struct edge{
int to,cost;
};
vector<edge> G[maxn];

int dist[maxn];//最短路
int dist2[maxn];//次短路

void solve(){
priority_queue<P,vector<P>,greater<P> > que;
fill(dist,dist+N,INF);
fill(dist2,dist2+N,INF);
dist[0]=0;
que.push(P(0,0));

while(!que.empty()){
P p=que.top();
que.pop();
int v=p.second,d=p.first;

if(dist2[v]<d) continue;
for(int i=0;i<G[v].size();i++){
edge e=G[v][i];
int d2=d+e.cost;

if(dist[e.to]>d2){
swap(dist[e.to],d2);
que.push(P(dist[e.to],e.to));
}

if(dist2[e.to]>d2&&dist[e.to]<d2){
dist2[e.to]=d2;
que.push(P(dist2[e.to],e.to));
}
}
}

printf("%d\n",dist2[N-1]);
}

int main(){
scanf("%d%d",&N,&R);
for(int i=0;i<R;i++){
int u,v,d;
scanf("%d%d%d",&u,&v,&d);
u--;
v--;
G[u].push_back((edge){v,d});
G[v].push_back((edge){u,d});
}
solve();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息