您的位置:首页 > 运维架构

POJ-----2115---C Looooops扩展欧几里得

2016-11-27 04:01 330 查看
C Looooops

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24687Accepted: 6939
Description
A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming
that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input
The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop
and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output
The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the
loop does not terminate.

Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output
0
2
32766
FOREVER

给定一个循环for(int i = A; i != B; i += C) (i <= 2^k),问经多少次循环,次循环可以退出,i大于2^k时,即溢出就变为0,重新循环
因此题目为求C*x 与 B-A+n*2^k同模于 2^k,即C*x 与 B-A同模于 2^k

转化为C*x+y*2^k=B-A,求最小整数解,扩展欧几里得即可,注意判断B-A是否是gcd(C, 2^k)的倍数

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e5+10;
const int MOD = 1e9+7;
int n[20], m[20];
void ex_gcd(LL a, LL b, LL& d, LL& x, LL& y){
if(!b){
d = a;
x = 1;
y = 0;
}
else{
ex_gcd(b, a%b, d, y, x);
y -= x*(a/b);
}
}
int main(){
LL a, b, c, d, A, B, C, k, x, y;
int kcase = 1;
while(scanf("%lld%lld%lld%lld", &A, &B, &C, &k) == 4 && A || B || C || k){
a = C;
b = (LL)1 << k;
c = B-A;
ex_gcd(a, b, d, x, y);
if(c%d) printf("FOREVER\n");
else{
c /= d;
x *= c;
b /= d;
x = (x%b+b)%b;
printf("%lld\n", x);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: