您的位置:首页 > 其它

POJ 1797 - Heavy Transportation(dijkstra变形)

2016-11-26 22:23 288 查看
Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K

Total Submissions: 31541 Accepted: 8362

Description

Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1

3 3

1 2 3

1 3 4

2 3 5

Sample Output

Scenario #1:

4

题意:

从1到n有若干条路径,每个路径都有最大承载量(路径中最大边的长度)。

求所有路径中最大的最大承载量。

解题思路:

dijkstra变形。贪心的去找从当前的点出发的边最大的下一个点、

AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn = 1e3+5;
int dis[maxn];
bool vis[maxn];
int mp[maxn][maxn];
int n;
void dijkstra()
{
for(int i = 1;i <= n;i++)   dis[i] = mp[1][i],vis[i] = 0;
for(int i = 1;i <= n;i++)
{
int minn = -1,index = -1;
for(int j = 1;j <= n;j++)
if(!vis[j] && dis[j] > minn)    minn = dis[j],index = j;
vis[index] = 1;
for(int j = 1;j <= n;j++)
if(!vis[j] && dis[j] < min(dis[index],mp[index][j]))
dis[j] = min(dis[index],mp[index][j]);
}
}
int main()
{
int T;
scanf("%d",&T);
int flag = 1;
while(T--)
{
int m;
scanf("%d%d",&n,&m);
for(int i = 1;i <= n;i++)
for(int j = 1;j <= n;j++)
mp[i][j] = 0;
while(m--)
{
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
mp[u][v] = w,mp[v][u] = w;
}
dijkstra();
printf("Scenario #%d:\n",flag++);
printf("%d\n\n",dis
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: