您的位置:首页 > 其它

POJ 3624 Charm Bracelet

2016-11-25 22:20 239 查看
POJ3624:Charm Bracelet
Description
Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di
Output* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input4 6
1 4
2 6
3 12
2 7Sample Output23
 
       题意:经典0—1背包问题,有n个物品,编号为i的物品的重量为w[i],价值为v[i],现在要从这些物品中选一些物品装到一个容量为m的背包中,
使得背包内物体在总重量不超过m的前提下价值尽量大
代码示例:
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int weight[40000],price[40000];
int dfs[40000];
int main()
{
    int max_weight,num,i,j;
    while(~scanf("%d%d",&num,&max_weight))
    {

    for(i=0;i<num;i++)
    {
        scanf("%d%d",&weight[i],&price[i]);
    }
    memset(dfs,0,sizeof(dfs));
    for(i=0;i<num;i++)
    {
        for(j=max_weight;j>=weight[i];j--)
        {
                dfs[j] =dfs[j-weight[i]] + price[i]>=dfs[j]?dfs[j-weight[i]] + price[i]:dfs[j];
        }
    }
    printf("%d\n",dfs[max_weight]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: