您的位置:首页 > 其它

(POJ1376)Cash Machine <多重背包问题变形,二进制优化>

2016-11-25 14:49 453 查看
Cash Machine

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350

633 4 500 30 6 100 1 5 0 1

735 0

0 3 10 100 10 50 10 10

Sample Output

735

630

0

0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

Southeastern Europe 2002

题意:

有一个cash值,和N个不同面值的钱,每种的个数为n,面值为d,问用这些钱可以抽出小于或等于cash值的最大钱数?

分析:

题意是一个标准的多重背包问题,但是cash<=100000,N<=10,n<=1000

普通的算法时间复杂度为10的九次方了,超时

所以我们要进行优化:

这里我们用二进制来优化:将某面值的钱分为几份:分别包含1,2,4,。。。,2^(k-1),n-(2^k + 1)张。例如13分为:1,2,4,6

这样做从1~n都能被上面的某些组合所表示。

所以问题就变成了01背包问题了。

注意:今后所有的多重背包问题都尽量用二进制优化

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int w[110];
int dp[100010];
int cash,N,n,d,num;
int s[11] = {1,2,4,8,16,32,64,128,256,512,1024};

int main()
{
while(scanf("%d%d",&cash,&N)!=EOF)
{
memset(dp,0,sizeof(dp));
num = 1;
for(int i=1;i<=N;i++)
{
scanf("%d%d",&n,&d);
if(n > 0)
{
int j;
for(j=10;j>=0;j--)
if(n - s[j] + 1 > 0) break;
for(int k=0;k<j;k++)
{
w[num++] = s[k]*d;
}
w[num++] = (n - s[j] + 1)*d;
}
}
for(int i=1;i<num;i++)
{
for(int j=cash;j>=w[i];j--)
dp[j] = max(dp[j],dp[j-w[i]]+w[i]);
}
printf("%d\n",dp[cash]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: