您的位置:首页 > 其它

POJ2084——Game of Connections

2016-11-23 11:26 459 查看
Game of Connections

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8343 Accepted: 4146
Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every
number must be connected to exactly one another. 

And, no two segments are allowed to intersect. 

It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?
Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1. 

You may assume that 1 <= n <= 100.
Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.
Sample Input
2
3
-1

Sample Output
2
5

Source

Shanghai 2004 Preliminary
题意:

给你2n个数,让这些数按照顺序围成一个圈,任意两个数可以连接,但是每个数只能连接一次,且连线不能交叉,问你一共有多少种方式。

解:

完全符合卡特兰数的通式,但是数据量不算小所以要使用大数进行计算。

卡特兰数:

①令h(0)=1,h(1)=1:
h(n)= h(0)*h(n-1)+h(1)*h(n-2) + ... + h(n-1)*h(0) (n>=2)


②递推式:h(n)=h(n-1)*(4*n-2)/(n+1);

③递推式另类解:h(n)=c(2n,n)-c(2n,n-1)(n=0,1,2,...)

#include <stdio.h>

int a[105][105];
int b[105];

void catalan()
{
a[1][0] = b[1] = 1;
int len = 1;
for(int i = 2; i <= 100; i++)
{

int carry = 0;
for(int j = 0; j < len; j++)
{
a[i][j] = a[i-1][j]*(4*(i-1)+2);
int temp = a[i][j] + carry;
a[i][j] = temp % 10;
carry = temp / 10;
}
while(carry)
{
a[i][len++] = carry % 10;
carry /= 10;
}
carry = 0;
for(int j = len-1; j >= 0; j--)
{
int temp = carry*10 + a[i][j];
a[i][j] = temp/(i+1);
carry = temp%(i+1);
}
while(!a[i][len-1])
len --;
b[i] = len;
}
}

int main()
{
int n;
catalan();
while(~scanf("%d",&n))
{
for(int i=b
-1;i>=0;i--)
{
printf("%d",a
[i]);
}
printf("\n");
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息