您的位置:首页 > 其它

并查集的应用:hdu 1213

2016-11-22 20:24 204 查看
Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4


AC代码:

# include <stdio.h>

int group[1005];
int depth[1005];

void init()//初始化组别
{
int i;
for (i = 0; i < 1005; i ++)
{
group[i] = i;
depth[i] = 1;
}
}

int find(int e) //查找根并把同组的都连到根部
{
if (group[e] == e)
{
return e;
}
else
{
return group[e] = find(group[e]);
}
}

void unite(int e1, int e2) //连接两个不同的组
{
e1 = find(e1);
e2 = find(e2);

if (depth[e1] < depth[e2]) //把树的深度小 的连接到深度大的
{
group[e1] = e2;
}
else
{
group[e2] = e1;
if (depth[e1] == depth[e2])
{
depth[e1] ++;
}
}
}

int main(void)
{
int t;
scanf("%d", &t);
while (t--)
{
int n, m;
int i;
int count = 0;
init();
scanf("%d %d", &n, &m);
for (i = 1; i <= m; i++)
{
int head, tail;
scanf("%d %d", &head, &tail);
unite(head, tail);
}

for (i = 1; i <= n; i++)
{
if (group[i] == i)
{
count++;
}
}
printf("%d\n", count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 并查集