您的位置:首页 > 其它

UVA - 11889 Benefit【LCM】

2016-11-22 12:28 155 查看
Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he

who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B

equals to C and he will pay back a round bill. Or otherwise take some snack instead of the remaining of

his money. He believes that finding such a number is hard enough that dissuades students from paying

that.

You should write a program that help poor students giving the appropriate amount of money to

Yaghoub. Of course if there are several answers you go for students’ benefit which is the lowest of them.

Input

The first line begin with an integer T (T ≤ 100000), the number of tests. Each test that comes in a

separate line contains two integers A and C (1 ≤ A, C ≤ 107).

Output
Print the lowest integer B such that LCM(A, B) = C in a single line. If no such integer exists, print

‘NO SOLUTION’ instead. (Quotes for clarity)

Sample Input

3

2 6

32 1760

7 16

Sample Output

3

55

NO SOLUTION



已知A,C 求最小的B满足LCM(A,B)=C;

AC代码:

#include<cstdio>

typedef long long LL;

LL GCD(LL a,LL b) {
return !b?a:GCD(b,a%b);
}
LL LCM(LL a,LL b) {
return a/GCD(a,b)*b;
}

int main() {
int T; scanf("%d",&T);
while(T--) {
int A,C; scanf("%d%d",&A,&C);
int B=C/A;
if(A*B!=C) printf("NO SOLUTION\n");
else {
for(int i=1; ;++i) {
if(LCM(A,B*i)==C) {
B*=i; break;
}
}
printf("%d\n",B);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: