您的位置:首页 > 其它

POJ-2488-A Knight's Journey

2016-11-22 11:08 375 查看
A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42499 Accepted: 14446
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a
p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the
chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany

题目大意:给你一个n*m的棋盘问你骑士能否遍历棋盘上的所有点,如果可以按字典序遍历;

[b]所以在DFS时搜索的次序要有先后
[/b]






#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

int dx[8]={-1,1,-2,2,-2,2,-1,1};
int dy[8]={-2,-2,-1,-1,1,1,2,2};
int vist[27][27];

struct node
{
int x,y;
}s[26*26];

int n,m,flag,cnt;

void DFS(int X,int Y)
{
if(n*m == cnt)
{
flag = 1;
return;
}
for(int l = 0; l < 8; l++)
{
int sx = X+dx[l];
int sy = Y+dy[l];
if(sx>=0 && sx<n && sy>=0 && sy<m && !vist[sx][sy])
{
s[cnt].x = sx;
s[cnt++].y = sy;
vist[sx][sy] = 1;
DFS(sx,sy);
if(!flag)
{
vist[sx][sy] = 0;
cnt--;
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
for(int i = 1; i <= t; i++)
{
scanf("%d%d",&n,&m);
cnt = 1;
flag = 0;
memset(vist,0,sizeof(vist));
vist[0][0] = 1;
DFS(0,0);
printf("Scenario #%d:\n",i);
if(flag)
{
for(int j = 0; j < cnt; j++)
{
printf("%c%d",s[j].y+'A',s[j].x+1);
}
cout<<endl<<endl;
}
else
cout<<"impossible"<<endl<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息