您的位置:首页 > 其它

HDU2717 Catch That Cow (BFS)

2016-11-22 10:49 239 查看
Catch That Cow
Time Limit:2000MS     Memory Limit:32768KB     64bit
IO Format:
%I64d & %I64u

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer
John has two modes of transportation: walking and teleporting. 

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute 

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute. 

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17


Sample Output

4


Hint



The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <cstdio>
#include <cstring>
#include <queue>
#define N 100010

using namespace std;

int map
;

struct node{
int x;
int step;
};

int Judge(int x){
if(x < 0 || x > N || map[x])
return 0;
return 1;
}

int bfs(int n, int k){
queue <node> Q;
node temp,a;

a.x = n;
a.step = 0;
map
= 1;
Q.push(a);

while(!Q.empty()){
a = Q.front();
Q.pop();

if(a.x == k)
return a.step;

temp = a;

temp.x = a.x + 1;
if(Judge(temp.x)){
temp.step = a.step + 1;
map[temp.x] = 1;
Q.push(temp);
}

temp.x = a.x - 1;
if(Judge(temp.x)){
temp.step = a.step + 1;
map[temp.x] = 1;
Q.push(temp);
}

temp.x = 2 * a.x;
if(Judge(temp.x)){
temp.step = a.step + 1;
map[temp.x] = 1;
Q.push(temp);
}
}
}

int main(){
int n,k;

while(~scanf("%d%d",&n,&k)){

memset(map,0,sizeof(map));

int ans = bfs(n,k);

printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: