您的位置:首页 > 编程语言 > C语言/C++

1002. A+B for Polynomials (25)

2016-11-21 09:47 309 查看

1002. A+B for Polynomials (25)

时间限制
400 ms

内存限制
65536 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi
(i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

写对这道题目真不容易,花了好几天换了好几个思路,附上代码和注意事项
#include<iostream>
#include<iomanip>
using namespace std;
#define MAX 1001
int main()
{
double a[MAX];
for(int i=0;i<MAX;i++)//全部初始化为0
{
a[i]=0;
}
int k1=0,k2=0;
int m=0;//n是项数,m是系数
double n=0.0;
cin>>k1;
for(int i=0;i<k1;i++)//输入多少组数字
{
cin>>m>>n;
a[m]+=n;//把每一项的值放入对应的第几项中去
}
cin>>k2;
for(int i=0;i<k2;i++)
{
cin>>m>>n;
a[m]+=n;
}
int num=0;
for(int i=0;i<MAX;i++)//有多少项
{
if(a[i]!=0)
{
num++;
}
}
cout<<num;
for(int i=MAX-1;i>0;i--)//从大到小输出
{
if(a[i]!=0)
{
cout<<" "<<i<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<a[i];
}
}
if(a[0]!=0)
{
cout<<" "<<"0"<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<a[0];
}
return 0;
}

首先,我做这道题,第一个思路就是弄一个结构体,比较方便的存储这里的项数和系数,但由于数字一直存不进去作罢。其实这个问题在我第二个思路里面也出现了,最后发现是我的项数和系数的类型都设成了int型,导致有小数点的项数根本存不进去,这是我后来发现的。
我的第二个思路是看了别人的博客才学会的,就是放进数组里面去,第几项放到数组里面的第几项里面去,然后系数就是它的值;
2.这里有很多格式要注意,比如,精确到1位小数,要用<<setiosflags(ios::fixed)<<setprecision(1)<< ,并且引入头文件iomanip,对了,最后一项0要注意,
是最后输出,注意格式

总之做了很久才做出来全对,开心



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT 算法竞赛