您的位置:首页 > 其它

poj1979 Red and Black (DFS)

2016-11-20 00:27 411 查看
Red and Black

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31990 Accepted: 17459
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13


题目大意:给定一个矩阵,由‘#’,'.' , '@'组成 ,其中’@‘是起点,’.‘表示可以走的地点,’#‘表示不能走的地点,问从起点开始,最多能走过多少格子(每次只能上下左右走一格)。

题解:直接dfs,标记把走过的地点标记为1,然后扫一遍标记的那个数组有多少个1,就得到答案了。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n, m;
char map[25][25];
int vis[25][25];
int ans;
int step[2][4] = {-1, 0, 0, 1,
0,-1, 1, 0};

void dfs(int r, int l)
{
for(int i = 0; i < 4; i++)
{
int rr, ll;
rr = r + step[0][i];
ll = l + step[1][i];
if(map[rr][ll] == '.')
{
map[rr][ll] = '#';
dfs(rr, ll);
vis[rr][ll] = 1;
}
}
}

int main()
{
while(cin >> m >> n && m != 0)
{
memset(vis, 0, sizeof(vis));
memset(map, '#', sizeof(map));
ans = 0;
int sr, sl;
for(int i = 0; i < n; i++)
{
for(int j = 0; j < m; j++)
{
cin >> map[i][j];
if(map[i][j] == '@')
{
sr = i;
sl = j;
}
}
}
vis[sr][sl] = 1;
dfs(sr, sl);
for(int i = 0; i < n; i++)
{
for(int j = 0; j < m; j++)
{
ans += vis[i][j];
}
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: