您的位置:首页 > 其它

poj 3278 Catch That Cow

2016-11-19 22:00 288 查看
Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 79534 Accepted: 25090
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题解:广搜利用的是队列
代码:
#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
int pos,step;
}a,next;
int K,vis[100000+10];
bool check(int x)
{
if(x<0||x>100000||vis[x])
return 0;
return 1;
}
int bfs(int x)
{
memset(vis,0,sizeof(vis));
queue<node> q;
a.pos=x;
a.step=0;
vis[a.pos]=1;
q.push(a);
while(!q.empty())
{
a=q.front();
q.pop();
if(a.pos==K)
{
return a.step;
}
next.pos=a.pos-1;
if(check(next.pos))
{
next.step=a.step+1;
q.push(next);
vis[next.pos]=1;
}
next.pos=a.pos+1;
if(check(next.pos))
{
next.step=a.step+1;
q.push(next);
vis[next.pos]=1;
}
next.pos=a.pos*2;
if(check(next.pos))
{
next.step=a.step+1;
q.push(next);
vis[next.pos]=1;
}
}
}
int main()
{
int N,ans;
while(~scanf("%d%d",&N,&K))
{
if(K<=N)
ans=N-K;
else
ans=bfs(N);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: