您的位置:首页 > 其它

哈理工OJ 1248 The kth great number(优先队列求第k大数)

2016-11-17 19:13 295 查看
题目链接:http://acm.hrbust.edu.cn/index.php?m=ProblemSet&a=showProblem&problem_id=1248

The kth great number

Time Limit: 1000 MS Memory Limit: 65536 K

Total Submit: 108(36 users) Total Accepted: 65(35 users) Rating: Special Judge: No

Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an ” I” followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3

I 1

I 2

I 3

Q

I 5

Q

I 4

Q

Sample Output

1

2

3

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

【中文题意】求第k大数是多少。

【思路分析】用优先队列求第k大数。

【AC代码】

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
struct cmp
{
bool operator()(int x,int y)
{
return x>y;
}
};

int main()
{
int n,k;
while(scanf("%d%d",&n,&k)==2)
{
priority_queue<int,vector<int>,cmp>q;
char c;
for (int i=1; i<=n; i++)
{
c=getchar();
while(c!='I'&&c!='Q')
{
c=getchar();
}
if (c=='I')
{
int now;
scanf("%d",&now);
q.push(now);
if (q.size()>k) q.pop();
}
else
{
printf("%d\n",q.top());
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  哈理工OJ