您的位置:首页 > 其它

【POJ 2456 Aggressive cows】+ 二分

2016-11-15 23:58 411 查看
Aggressive cows

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 11881 Accepted: 5808

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3

1

2

8

4

9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

对最大位置进行二分即可~~

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const LL INF = 0x3f3f3f;
int N,M;
LL pa[100010];
bool EF(LL x){
LL la = 1;
for(int i = 1 ; i < M ; i++){ // 找到M个满足条件的位置
int cut = la + 1;
while(cut <= N && pa[cut] - pa[la] < x)
cut++;
if(cut > N) return false;
la = cut;
}
return true;
}
int main()
{
while(scanf("%d %d",&N,&M) != EOF){
for(int i = 1 ; i <= N ; i++)
scanf("%lld",&pa[i]);
sort(pa + 1 ,pa + 1 + N);
LL low = 0,high = INF;
while(low < high - 1){
LL mid = (low + high) / 2;
if(EF(mid)) low = mid;
else high = mid;
}
printf("%lld\n",low);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj