您的位置:首页 > 其它

HDU 2054

2016-11-15 22:37 351 查看
A == B ?

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

 

Input

each test case contains two numbers A and B.

 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

 

Sample Input

1 2

2 2

3 3

4 3

 

Sample Output

NO

YES

YES

NO
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char a[100000], b[100000];
void change(char s[])
{
int i, len;
len = strlen(s);//判断字符串的长度
if (strstr(s, "."))//strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。
{
for (i = len - 1; s[i] == '0'; i--)//将字符串后的0消除
{
s[i] = '\0';
len--;
}
}
if (s[len - 1] == '.')//将字符换后的点消除s
s[len - 1] = '\0';
}

int main()
{

while (scanf("%s%s", a, b) != EOF)
{
change(a);
change(b);
if (strcmp(a, b))
printf("NO\n");
else
printf("YES\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: