您的位置:首页 > Web前端

2020: [Usaco2010 Jan]Buying Feed, II

2016-11-15 20:42 465 查看

2020: [Usaco2010 Jan]Buying Feed, II

Time Limit: 3 Sec  Memory Limit: 64 MB
Submit: 300  Solved: 220

[Submit][Status][Discuss]

Description

(buying.pas/buying.in/buying.out 128M 1S) Farmer John needs to travel to town to pick up K (1 <= K <= 100) pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents. The county
feed lot has N (1 <= N <= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell FJ as much as F_i
(1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound. Amazingly, a given point on the X axis might have more than one store. FJ starts at location 0 on this number line and can drive only in the positive direction, ultimately
arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit. What is the minimum amount FJ has to pay to buy and transport the K pounds of feed? FJ knows
there is a solution. Consider a sample where FJ needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5: 0 1 2 3 4 5 +---|---+---|---|---+ 1 1 1 Available pounds of feed 1 2 2 Cents per pound It is best for
FJ to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When FJ travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay 1*1 = 1 cents. When
FJ travels from 4 to 5 he is moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.
FJ开车去买K份食物,如果他的车上有X份食物。每走一里就花费X元。 FJ的城市是一条线,总共E里路,有E+1个地方,标号0~E。 FJ从0开始走,到E结束(不能往回走),要买K份食物。 城里有N个商店,每个商店的位置是X_i(一个点上可能有多个商店),有F_i份食物,每份C_i元。 问到达E并买K份食物的最小花费

Input

第1行:K,E,N 第2~N+1行:X_i,F_i,C_i.

Output

Sample Input

2 5 3

3 1 2

4 1 2

1 1 1

Sample Output

7

HINT

在离家较近的两家商店里各购买一吨饲料,

则花在路上的钱是 1 + 2 = 3,花在店里的钱是2 + 2 = 4

Source

Silver

本蒟蒻未看出是贪心,用dp解的

附代码:
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<climits>
#include<queue>
#include<stack>
#include<map>
#include<set>
#define N 101
using namespace std;
int n,m;
char mp

;
int num
,p
;
int cal(int x){int len=0;while(x){if(x&1)len++;x>>=1;}return len;}
bool check(int u)
{
for(int i=1;i<=m;i++)
{
int t=u&num[i];
if(cal(t)!=p[i])return false;
}
return true;
}int ans,cnt,fin
;
void print(int x)
{
int j=n;
while(x)
{
fin[j]=x&1;
x>>=1;j--;
}
for(int i=1;i<=n;i++)printf("%d",fin[i]);
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=1;i<=m;i++)
{
scanf("%s%d",mp[i]+1,&p[i]);
for(int j=n;j;j--)
if(mp[i][j]=='1')num[i]|=(1<<(n-j));
}
for(int i=1;i<(1<<n);i++)
if(check(i))ans=i,cnt++;
if(!cnt)printf("IMPOSSIBLE\n");
else if(cnt>1)printf("NOT UNIQUE\n");
else print(ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: