您的位置:首页 > 运维架构

1688: [Usaco2005 Open]Disease Manangement 疾病管理

2016-11-15 11:43 309 查看

1688: [Usaco2005 Open]Disease Manangement 疾病管理

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 608  Solved: 395

[Submit][Status][Discuss]

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible.
If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the
milk.

Input

* Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first
integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

Output

* Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2

0---------第一头牛患0种病

1 1------第二头牛患一种病,为第一种病.

1 2

1 3

2 2 1

2 2 1

Sample Output

5

OUTPUT DETAILS:

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two

diseases (#1 and #2), which is no greater than K (2).

HINT

Source

Silver

比较简单的状压dp,读懂题就应该可以搞掉,比较坑的是卡空间,要开滚动数组23333
处理出f数组后,dfs出所有组合更新ans

附代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<climits>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#define N 2001
using namespace std;
int n,d,k,ans;
int f[2][1<<16];
struct node{short int tot;int st;}p
;
void dfs(int u,int now,int cnt)
{
if(cnt==k)
{
ans=max(ans,f[n&1][now]);
return ;
}
for(int i=u+1;i<=d;i++)
dfs(i,now|(1<<(i-1)),cnt+1);
}
int main()
{
//	freopen("in.txt","r",stdin);
//	freopen("my.txt","w",stdout);
scanf("%d%d%d",&n,&d,&k);
for(int i=1;i<=n;i++)
{
scanf("%d",&p[i].tot);p[i].st=0;
for(int j=1,x;j<=p[i].tot;j++)
{
scanf("%d",&x);
p[i].st|=1<<(x-1);
}
}
/*
6 3 2
0
1 1
1 2
1 3
2 2 1
2 2 1
*/
f[1][p[1].st]=1;
for(int u=2;u<=n;u++)
{
for(int j=0;j<(1<<d);j++)
f[u&1][j]=f[!(u&1)][j];
for(int j=0;j<(1<<d);j++)
f[u&1][j|p[u].st]=max(f[u&1][j|p[u].st],f[!(u&1)][j]+1);
}dfs(0,0,0);
printf("%d\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: