您的位置:首页 > 其它

POJ 1703 Find them, Catch them(带权并查集)

2016-11-14 23:19 423 查看
[b]传送门[/b]
[b]Find them, Catch them[/b]

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 42463Accepted: 13065

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

[b][b]Sample Input[/b]

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4


Sample Output

Not sure yet.
In different gangs.
In the same gang.


思路

题意:有两个不同的帮派,每个帮派至少有一人。判断两人是否是同一帮派的。 题解:食物链的简化版 方法一: 因为有两个帮派,因此对于每个人只要创建 2 个元素 i - A,i - B,并利用 2*N 个元素建立并查集。 假设 x , y属于不同的帮派,x , y + N 则是同一个帮派,x + N , y 同理。因此只需要将(x , y + N) 和 (x + N , y) 合并即可。 方法二:带权并查集,利用r[ ]数组记录每个元素与其父亲节点的关系。 r[ x ] = 0 代表 x 与其父亲节点是同一个帮派的; r[ x ] = 1 代表 x 与其父亲节点是敌对帮派的; 一开始每个人都是自己的父亲节点 f[ x ] = x,每个人与自己的关系都是同属于一个阵营 r[ x ] = 0; 1、find( ) 函数寻找根节点的时候要不断更新 r[ ]数组 根据子节点与父节点的关系和父节点和爷爷节点的关系推到子节点和爷爷节点的关系。 很容易通过穷举发现其关系式:a 和 b 的关系为 r1, b 和 c 的关系为r2,则 a 和 c 的关系为: r3 = ( r1 + r2) % 2;
(爷爷,父亲)(父亲,儿子)(爷爷,儿子)
000
011
101
110
2、 Union的时候更新两棵树的关系

定义:fx 为 x的根节点, fy 为 y 的根节点,联合时,使得fa[ fy ] = fx;同时也要寻找 fx 和 fy 的关系,其关系为(r[ x ]  + 1 - r[ y ]) % 2;


因为确定了 x 和 y 的关系是 1 ,因此 r[ fy ] = (r[ x ] + 1 - r[ y ]) % 2;


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005;
int fa[maxn*3];

int find(int x)
{
int r = x;
while (r != fa[r])	r = fa[r];
int i = x,j;
while (i != r)
{
j = fa[i];
fa[i] = r;
i = j;
}
return r;
}

void unite(int x,int y)
{
x = find(x),y = find(y);
if (x != y)	fa[x] = y;
}

bool same(int x,int y)
{
return find(x) == find(y);
}

int main()
{
int T;
scanf("%d",&T);
while (T--)
{
int N,M,x,y;
char opt[5];
scanf("%d%d",&N,&M);
for (int i = 0;i <= 3*N;i++)	fa[i] = i;
while (M--)
{
scanf("%s %d %d",opt,&x,&y);
if (opt[0] == 'A')
{
if (find(x) == find(y))
printf("In the same gang.\n");
else if (same(x,y + N) && same(x + N,y))
printf("In different gangs.\n");
else
printf("Not sure yet.\n");
}
else if (opt[0] == 'D')
{
unite(x,y + N);
unite(x + N,y);
}
}
}
return 0;
}


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005;
int fa[maxn],r[maxn];

int find(int x)
{
if (fa[x] == x)	return fa[x];
int tmp = fa[x];
fa[x] = find(fa[x]);
r[x] = (r[tmp] + r[x]) % 2;
return fa[x];
}

void unite(int x,int y)
{
int fx = find(x),fy = find(y);
if (fx == fy)	return;
fa[fy] = fx;
r[fy] = (r[x] + 1 - r[y]) % 2;
}

int main()
{
int T;
scanf("%d",&T);
while (T--)
{
int N,M,x,y;
char opt[5];
scanf("%d%d",&N,&M);
for (int i = 0;i <= N;i++)	fa[i] = i,r[i] = 0;
while (M--)
{
scanf("%s %d %d",opt,&x,&y);
if (opt[0] == 'A')
{
if (find(x) == find(y))
{
if (r[x] == r[y])	printf("In the same gang.\n");
else	printf("In different gangs.\n");
}
else	printf("Not sure yet.\n");
}
else	unite(x,y);
}
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: