您的位置:首页 > 其它

文章标题 POJ 1258 : Agri-Net(最小生成树--kruskal)

2016-11-13 22:07 267 查看

Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

Sample Output

28

分析:裸的最小生成树,关系矩阵都给出了,只需要将边排一下序,然后加n-1条边,将答案记录下来。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n;
int mp[105][105];
int fa[105];//并查集
int find(int x){
return fa[x]==x?x:fa[x]=find(fa[x]);
}
struct node {
int x,y;
int dis;
};
node a[105*105];
bool cmp(node a,node b){
return a.dis<b.dis;
}
int main ()
{
while (scanf ("%d",&n)!=EOF){
for (int i=1;i<=n;i++){
fa[i]=i;//初始化
for(int j=1;j<=n;j++){
scanf ("%d",&mp[i][j]);
}
}
int cnt=0;
for (int i=1;i<=n-1;i++){
for (int j=i+1;j<=n;j++){//将上三角矩阵的边保存在下来
a[cnt].x=i;
a[cnt].y=j;
a[cnt++].dis=mp[i][j];
}
}
sort (a,a+cnt,cmp);//排序
int connect=0;//已连接的边
int ans=0;
for(int i=0;i<cnt;i++){
int x=a[i].x;
int y=a[i].y;
int fx=find(x),fy=find(y);
if (fx!=fy){
connect++;
fa[fx]=fy;
ans+=a[i].dis;
}
if (connect==n-1){//当连接的边有n-1条,就结束
break;
}
}
printf ("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj