您的位置:首页 > 产品设计 > UI/UE

hdoj 1005 Number Sequence (斐波那契数列 找循环节)

2016-11-13 18:55 465 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 158599    Accepted Submission(s): 38859


Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

 
因为对7取模,所以f(n)最多有7*7种可能结果,其中有一项一定是循环点,注意循环节不一定是从f(1) f(2) 开始的,(大神的解释)
代码:
#include <iostream>
#include<cstdio>
using namespace std;
int f[10000005];//??为什么开那么大才行,开到50以上不可以??
int main()
{
int a,b,n,m;
f[1]=1;f[2]=1;
while(scanf("%d%d%d",&a,&b,&n)&&(a||b||n))
{

m=0;
int i,j;
for(i=3;i<=n;i++)//找循环节,但是循环点不一定从f[1] f[2]开始
{

f[i]=(a*f[i-1]+b*f[i-2])%7;
for(j=2;j<i;j++)
{
if(f[i-1]==f[j-1]&&f[i]==f[j])
{
m=i-j;
break;
}
}
if(m>0)
break;
}
if(m>0)
{
f
=f[(n-j)%m+j];
}
printf("%d\n",f
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: