您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2016-11-12 20:56 246 查看

数据结构实验之链表三:链表的逆置

Time Limit: 1000MS
Memory Limit: 65536KB
[align=center][/align]

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Example Input

12 56 4 6 55 15 33 62 -1


Example Output

62 33 15 55 6 4 56 12


Hint

不得使用数组。

Author

 
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *creat(struct node *head)
{
int i,m;
struct node *p,*q,*tail;
for(i=0;;i++)
{
scanf("%d",&m);
if(m==-1)
return head;
p=(struct node *)malloc(sizeof(struct node));
p->data=m;
p->next=head->next;
head->next=p;
}
}
int main()
{
int i,j,n,m,k,t;
struct node *head,*p,*q,*tail;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
head=creat(head);
p=head;
q=p->next;
free(p);
p=q;
i=0;
while(p!=NULL)
{
if(i==0)
printf("%d",p->data);
else
printf(" %d",p->data);
q=p->next;
free(p);
p=q;
i++;
}
printf("\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: