您的位置:首页 > 其它

【HDU 5980 Find Small A】+ 2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

2016-11-12 17:09 477 查看
Find Small A

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 324 Accepted Submission(s): 162

Problem Description

As is known to all,the ASCII of character ‘a’ is 97. Now,find out how many character ‘a’ in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).

Input

The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai≤2^32 - 1) follow

Output

Output one line,including an integer representing the number of ‘a’ in the group of given numbers.

Sample Input

3

97 24929 100

Sample Output

3

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

每个数的二进制位每 8 位 为一个字符,有多少个等于’a’的ASCII字符~

AC代码:

#include<bits/stdc++.h>
int pa[33];
int main()
{
int n,a,nl,ans;
while(scanf("%d",&n) != EOF){
ans = 0;
while(n--){
memset(pa,0,sizeof(pa));
scanf("%d",&a);
nl = 0;
while(a){
pa[++nl] = a & 1;
a >>= 1;
}
for(int i = 1 ; i <= nl; i += 8){
int sum = 0,p = 1;
for(int j = i ; j <= i + 7 ; j++){
sum += p * pa[j];
p <<= 1;
}
if(sum == 97) ans++;
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐