您的位置:首页 > 其它

bca5 简单枚举类型——植物与颜色

2016-11-11 23:45 435 查看


简单枚举类型——植物与颜色

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 


Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。


Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 


Example Input

blue
yellow
purple



Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.


#include<stdio.h>
#include<string.h>
int main()
{
char a[50];
while(gets(a)!=NULL)
{
if(strcmp(a,"red")==0)
printf("Rose are red.\n");
else if(strcmp(a,"orange")==0)
printf("Poppies are orange.\n");
else if(strcmp(a,"yellow")==0)
printf("Sunflower are yellow.\n");
else if(strcmp(a,"green")==0)
printf("Grass are green.\n");
else if(strcmp(a,"blue")==0)
printf("Bluebells are blue.\n");
else if(strcmp(a,"violet")==0)
printf("Violets are violet.\n");
else
printf("I don't know about the color %s.\n",a);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: