您的位置:首页 > 其它

HDU 1058 Humble Numbers 【暴力(DFS)】

2016-11-11 13:26 405 查看


Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24389    Accepted Submission(s): 10688

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

直接暴力解答数节点数太多,优化一下,不计算重复的数就行了,解答树上就几千个节点,

 还有格式注意111是th;

AC代码:

#include<cstdio>
#include<algorithm>

using namespace std;

const int INF=2e9;
typedef long long LL;
const int b[]={2,3,5,7};
int a[111111],tota=0;
const char *format[]={"st","nd","rd","th"};

void DFS(LL num,LL fn) {
if(num>INF) return ;
a[tota++]=num;
int i=0;
while(fn!=b[i]) ++i;
for( ;i<4;++i) {
if(1LL*INF/num>=b[i]) DFS(num*b[i],b[i]);
else return ;
}
}
int main()
{
DFS(1,2); sort(a,a+tota); //unique(a,a+tota);
int N;
while(~scanf("%d",&N),N) {
int b1=N%10,b2=N%100;
printf("The %d",N);
if(b1==1||b1==2||b1==3) {
if(b2==11||b2==12||b2==13) printf("th ");
else printf("%s ",format[b1-1]);
}
else printf("th ");
printf("humble number is %lld.\n",a[N-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: