您的位置:首页 > 其它

HDU2579--Dating with girls(2)--(DFS, 判重)

2016-11-11 11:31 281 查看

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1418 Accepted Submission(s): 393



[align=left]Problem Description[/align]
If you have solved the problem Dating with
girls(1).I think you can solve this problem too.This problem is also
about dating with girls. Now you are in a maze and the girl you want to
date with is also in the maze.If you can find
the girl, then you can date with the girl.Else the girl will date with
other boys. What a pity!

The Maze is very strange. There are many stones in the maze. The stone
will disappear at time t if t is a multiple of k(2<= k <= 10), on
the other time , stones will be still there.

There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’
indicates the blank which you can move on, ‘#’ indicates stones. ’Y’
indicates the your location. ‘G’ indicates the girl's location . There
is only one ‘Y’ and one ‘G’. Every seconds you can move
left, right, up or down.



[align=left]Input[/align]
The first line contain an integer T. Then T
cases followed. Each case begins with three integers r and c (1 <= r ,
c <= 100), and k(2 <=k <= 10).

The next r line is the map’s description.

[align=left]Output[/align]
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".

[align=left]Sample Input[/align]

1
6 6 2

...Y..

...#..

.#....
...#..
...#..
..#G#.

[align=left]Sample Output[/align]

7

[align=left]Source[/align]
HDU 2009-5 Programming Contest

[align=left]Recommend[/align]
lcy

每秒移动一格, 只能上下左右移动
这道题是一个搜索的题目, 因为要求到达的最短时间, 用BFS会更好一些,
需要注意的一点是, 石头会在某个时间消失, 这样的话, 不仅在搜索时需要结合当前时间判断此地块是否有石头, 路径判重时也要注意
普通的搜索题目判重时是不能重复经过同一地块(会导致状态相同,从而重复搜索), 而这道题目中两个状态相同是指在同一地块的前提下, 距离下一次石头消失的时间相同.因此需要用一个三维数组, vis[MAXN][MAXN][K_MAXN] 标记状态
代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m,k,sx,sy,ex,ey;
struct haha
{
int x, y, step;
}q,temp;
char map[111][111];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int vis[111][111][11];
void BFS()
{
int i;
q.x=sx;
q.y=sy;
q.step=0;
queue<struct haha>que;
memset(vis,0,sizeof(vis));
vis[sx][sy][0]=1;
que.push(q);
while(!que.empty())
{
temp=que.front();
que.pop();
if(temp.x==ex&&temp.y==ey)
{
printf("%d\n",temp.step);
return ;
}
for(i=0;i<4;i++)
{
int xx,yy;
xx=temp.x+dir[i][0];
yy=temp.y+dir[i][1];
if(xx>=0&&xx<n&&yy>=0&&yy<m&&(map[xx][yy]!='#'||(temp.step+1)%k==0)&&!vis[xx][yy][(temp.step+1)%k])
{
q.step=temp.step+1;
q.x=xx;
q.y=yy;
vis[xx][yy][(temp.step+1)%k]=1;
que.push(q);
}
}
}
printf("Please give me another chance!\n");
}
int main()
{
int i,j,cas;
scanf("%d",&cas);
while(cas--)
{
scanf("%d %d %d",&n,&m,&k);
for(i=0;i<n;i++)
{
scanf("%s",map[i]);
for(j=0;j<m;j++)
{
if(map[i][j]=='Y')  {sx=i;sy=j;}
else if(map[i][j]=='G') {ex=i;ey=j;}
}
}
BFS();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: