您的位置:首页 > 其它

hdu 1016 dfs+回溯

2016-11-11 11:10 239 查看


Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13139    Accepted Submission(s): 6837


Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST === 

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution'
if there is no correct combination. Use the exact format shown below."

 

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

 

Sample Output

LKEBA
YOXUZ
GHOST
no solution
题意:每组给定一个数,给定一个字符串,截取长度为5的字串,(用题目中给定的方法计算出一个数值)与给定的相等,优先输出大的字串
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include<algorithm>
using namespace std;
int vis[30],n,sum; //标记数组
char s[30],ans[30],t[30];
void fun(int k)
{
if(k==5)
{
int x;
x=(t[0]-'A'+1)-(pow(t[1]-'A'+1,2))+(pow(t[2]-'A'+1,3))-(pow(t[3]-'A'+1,4))+(pow(t[4]-'A'+1,5));
if(x==sum&&strcmp(t,ans)>0) //优先输出字符串大的
{
strcpy(ans,t);
}
return;
}
for(int i=0;i<n;i++)
{
if(vis[s[i]-'A']==0)
{
t[k]=s[i];
vis[s[i]-'A']=1;
fun(k+1);
vis[s[i]-'A']=0; //回溯
}
}
}
int main()
{
while(~scanf("%d %s",&sum,s))
{
if(sum==0&&strcmp(s,"END")==0)
break;
memset(vis,0,sizeof(vis));
memset(ans,'\
b584
0',sizeof(ans)); // 初始化
memset(t,'\0',sizeof(t));
n=strlen(s);
fun(0);
if(strlen(ans)==0)
printf("no solution\n");
else
printf("%s\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: