您的位置:首页 > 其它

bzoj1636: [Usaco2007 Jan]Balanced Lineup ——by lethalboy

2016-11-11 09:34 357 查看

1636: [Usaco2007 Jan]Balanced Lineup

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 777  Solved: 561

[Submit][Status][Discuss]

Description

For the daily milking, Farmer John's N cows (1 <= N <= 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things
simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height. Farmer John has made a list of Q (1 <= Q <= 200,000) potential groups of cows and their
heights (1 <= height <= 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
每天,农夫 John 的N(1 <= N <= 50,000)头牛总是按同一序列排队. 有一天, John 
决定让一些牛们玩一场飞盘比赛. 他准备找一群在对列中为置连续的牛来进行比赛. 
但是为了避免水平悬殊,牛的身高不应该相差太大. 
John 准备了Q (1 <= Q <= 180,000) 个可能的牛的选择和所有牛的身高 (1 <= 
身高 <= 1,000,000). 他想知道每一组里面最高和最低的牛的身高差别. 
注意: 在最大数据上, 输入和输出将占用大部分运行时间. 

Input

* Line 1: Two space-separated integers, N and Q. * Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i * Lines N+2..N+Q+1: Two integers A and B (1 <= A <= B <= N), representing
the range of cows from A to B inclusive.

Output

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Input

* Lines 1..Q: Each line contains a single integer that is a response

to a reply and indicates the difference in height between the

tallest and shortest cow in the range.

Sample Output

6

3

0

HINT

Source

Silver

本来想写个线段树水过的,但突然想起练练ST表,然后发现自己好久不写ST表wa到哭,终于扣了hzwer的代码拿去拍,A掉了,所以还是要多练一些有优势但有容易被替代的算法。。。。。

附代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<climits>
#include<cstring>
#include<string>
#include<queue>
#include<map>
#define N 100005
using namespace std;
int f
[50],g
[50],n,q,a
,s[50];
int solve(int x,int y)
{
int t=log2((double)(y-x+1));
if(!t||((1<<t)+x>y))return f[x][t];
return max(solve((1<<t)+x,y),f[x][t]);
}
int ask(int x,int y)
{
int t=log2((double)(y-x+1));
if(!t||((1<<t)+x>y))return g[x][t];
return min(ask((1<<t)+x-1,y),g[x][t]);
}
int main()
{
scanf("%d%d",&n,&q);
for(int i=1;i<=n;i++)scanf("%d",&a[i]);
for(int i=1;i<=n;i++)for(int j=0;j<=49;j++)g[i][j]=0x3f3f3f3f;
for(int i=1;i<=n*2;i++)f[i][0]=g[i][0]=a[i];s[0]=1;
for(int i=1;i<=25;i++)s[i]=s[i-1]*2;
for(int k=1,j=2;j<=n;j<<=1,k++)
for(int i=1;i<=n;i++)
{
if(i+s[k-1]<=n)f[i][k]=max(f[i][k-1],f[i+s[k-1]][k-1]);
if(i+s[k-1]<=n)g[i][k]=min(g[i][k-1],g[i+s[k-1]][k-1]);
}
for(int i=1,x,y;i<=q;i++)
{
scanf("%d%d",&x,&y);
if(x>y)swap(x,y);
printf("%d\n",solve(x,y)-ask(x,y));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: