您的位置:首页 > 编程语言 > C语言/C++

POJ 1703 Find them, Catch them

2016-11-10 21:08 459 查看
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source
POJ Monthly--2004.07.18
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

带偏移量的并查集~

这题比关押罪犯难多了啊……

 对于每一个节点,记录两个值:它的“度”和它的父亲;“度”记录的是在哪个组,随着寻找根节点可以顺便更新,并不绝对。

#include<cstdio>
#include<cstring>

int t,n,m,x,y,fa[200001],set[200001],k1,k2;
char s[2];

int findd(int u)
{
if(fa[u]==u) return u;
int kkz=findd(fa[u]);
set[u]=(set[u]+set[fa[u]])%2;
return fa[u]=kkz;
}

void add(int u,int v)
{
int kkz1=findd(u),kkz2=findd(v);
fa[kkz1]=kkz2;
if(!set[v]) set[kkz1]=1-set[u];
else set[kkz1]=set[u];
}

int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++) fa[i]=i,set[i]=0;
while(m--)
{
scanf("%s%d%d",s,&x,&y);
if(s[0]=='A')
{
int kkz1=findd(x),kkz2=findd(y);
if(kkz1!=kkz2) printf("Not sure yet.\n");
else if(set[x]==set[y]) printf("In the same gang.\n");
else printf("In different gangs.\n");
}
else add(x,y);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 并查集