您的位置:首页 > 其它

POJ 1426Find The Multiple(DFS)

2016-11-10 15:23 375 查看

Find The Multiple

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28019Accepted: 11629Special Judge
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing
no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them
is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

unsigned __int64的最大值: 18446744073709551615
long long -9223372036854775808 ~ +9223372036854775807 (8Bytes)

#include <stdio.h>

int n,flag;

void DFS(unsigned long long a,int step)
{
if(flag||step==19)
{
return ;
}
if(a%n==0)
{
printf("%I64u\n",a);
flag=1;
return ;
}
else
{
DFS(a*10,step+1);
DFS(a*10+1,step+1);
}
return ;
}
int main()
{
while(scanf("%d",&n),n)
{
flag=0;
DFS(1,0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: