您的位置:首页 > 其它

POJ 2955 (区间dp)

2016-11-08 15:25 225 查看
Brackets

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Submit

Status

Practice

_

Appoint description:

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,

if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and

if a and b are regular brackets sequences, then ab is a regular brackets sequence.

no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))

()()()

([]])

)[)(

([][][)

end

Sample Output

6

6

4

0

6

题意:左右括号匹配,能匹配的算两个,然后让你找到最大的匹配数

题解:区间dp,从后往前弄

#include <cstdio>
#include <cstring>
#define M 110
char str[M];
int dp[M][M];
bool cmpss(char a, char b)
{
if(a == '(' && b == ')')
{
return true;
}
else if(a == '[' && b == ']')
{
return true;
}
return false;
}
int Max(int a, int b)
{
return a > b ? a : b;
}
int main()
{
int n;
while(1)
{
scanf("%s", str+1);
if(!strcmp(str+1, "end"))
{
break;
}
memset(dp, 0,sizeof(dp));
n = strlen(str+1);
for(int i=n-1; i>=1; i--)//区间dp做了几道题后发现都是从后向前比很省事
{
for(int j=i+1; j<=n; j++)
{
dp[i][j] = dp[i+1][j];//一般外围都需要赋予一个初值,才会出现对比
if(str[i] == '(' || str[i] == '[')//先行判断一下需不需要比
{
for(int k=i+1; k<=j; k++)
{
if(cmpss(str[i], str[k]))
{
dp[i][j] = Max(dp[i][j], dp[i+1][k-1] + dp[k+1][j] + 2);
//i 与 j 就是两个,再加上包括的和后面的,就是应有的,对比取最大
}
}
}
}
}
printf("%d\n", dp[1]
);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: