您的位置:首页 > 其它

HDOJ-【1016 Prime Ring Problem】

2016-11-08 14:12 357 查看

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 44390    Accepted Submission(s): 19676


[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

[align=left]Input[/align]
n (0 < n < 20).

 

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

[align=left]Sample Input[/align]

6
8

 

[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

最近要刷DFS,BFS的题目这是第二道题目,自己写出来的,很高兴

好好想想你就会了

#include<cstdio>
#include<cstring>
int prime[30];
int ans[30],vis[30],n,tag,test;
void Init()
{
int i,j;
for(i=0;i<25;++i)
prime[i]=0;
prime[0]=prime[1]=1;
for(i=2;i<25;++i)
{
for(j=2*i;j<25;j+=i)
prime[j]=1;
}
}
void dfs(int r,int pos)
{
if(pos==n&&!prime[r+1])
{
if(tag)
printf("Case %d:\n",test);
for(int i=0;i<n-1;++i)
printf("%d ",ans[i]);
printf("%d\n",ans[n-1]);
tag=0;
}
for(int j=2;j<=n;++j)
{
if(!prime[r+j]&&!vis[j])
{
ans[pos]=j;
vis[j]=1;
dfs(j,pos+1);
vis[j]=0;
}
}
}
int main()
{
test=0;
Init();
while(~scanf("%d",&n))
{
tag=1;
++test;
memset(vis,0,sizeof(vis));
ans[0]=1;
dfs(1,1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: