您的位置:首页 > 大数据 > 人工智能

贪心 ~HDU 1789 Doing Homework again

2016-11-08 02:04 405 查看
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12305    Accepted Submission(s): 7228


Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

 

Output

For each test case, you should output the smallest total reduced score, one line per test case.

 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

 

Sample Output

0
3
5

 

Author

lcy

 

Source

2007省赛集训队练习赛(10)_以此感谢DOOMIII

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1257 1978 1421 2159 1159 

贪心水题

排序 + bool判断一下#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

struct T {
int d,s;
}a[1005];

bool cmp(const T &a,const T &b) {
return a.s > b.s;
}

int main()
{
int n,t,sum;
scanf("%d",&n);
while(n--)
{
scanf("%d",&t);
sum = 0;
bool b[1005] = {0};
for(int i=0;i<t;i++)
{
scanf("%d",&a[i].d);
}
for(int i=0;i<t;i++)
{
scanf("%d",&a[i].s);
}
sort(a,a+t,cmp);
for(int i=0;i<t;i++)
{
int j;
for(j=a[i].d;j>=1;j--)
{
if(!b[j])
{
b[j] = true;
break;
}
}
if(!b[j])
{
sum += a[i].s;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心 HDU 水题 ACM