您的位置:首页 > 其它

POJ 2407 Relatives

2016-11-07 21:37 435 查看
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 13920Accepted: 6965
Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output

For each test case there should be single line of output answering the question posed above.
Sample Input

7
12
0

Sample Output

6
4

Source

Waterloo local 2002.07.01

#include<cstdio>
int euler_phi(int p){
int phi=p;
for(int i=2;i*i<=p;i++){
if(!(p%i)){
phi=phi-phi/i;
while(!(p%i))
p/=i;
}
}
if(p>1)
phi=phi-phi/p;
return phi;
}
int main(){
int p;
while(scanf("%d",&p),p)
printf("%d\n",euler_phi(p));
return 0;
}


裸的欧拉函数
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: