您的位置:首页 > 其它

HDU 5974 A Simple Math Problem (数学)

2016-11-07 09:34 483 查看

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 86    Accepted Submission(s): 49

[align=left]Problem Description[/align]

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b


 

[align=left]Input[/align]
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

[align=left]Output[/align]
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

[align=left]Sample Input[/align]

6 8
798 10780

 

[align=left]Sample Output[/align]

No Solution
308 490

 

[align=left]Source[/align]
2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

题意:两个整数x,y满足x+y=a,lcm(x,y)=b,问两个数是多少。
思路:一开始只能想到暴力枚举,果不其然的T了。然后就陷入了对数学的无限纠结中,怎么想都想不到如何化简,最后在大佬们的指导下终于会了,其实主要就是没想到gcd(a,b)=c这个关键地方,同时也知道了一条性质:如果x与y互质,那么xy和x+y肯定互质。中间判断是否有解的时候要注意想到所有情况。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;

int gcd(int a,int b){
return b==0?a:gcd(b,a%b);
}

int main(){
int a,b;
while(~scanf("%d %d",&a,&b)){
int c=gcd(a,b);
a=a/c;
b=b/c;
int g=a*a-4*b;
if(g<0)
puts("No Solution");
else{
int g2=sqrt(g);
if(g2*g2!=g)
puts("No Solution");
else{
if((a-g2)%2!=0||(a+g2)%2!=0)
puts("No Solution");
else{
int ans1=(a-g2)/2*c;
int ans2=(a+g2)/2*c;
if(ans1>0&&ans2>0){
if(ans1>ans2){
int temp=ans1;
ans1=ans2;
ans2=temp;
}
printf("%d %d\n",ans1,ans2);
}
}
}
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: