您的位置:首页 > 其它

HDU-5583 Kingdom of Black and White(思维)

2016-11-06 16:30 495 查看


Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2398 Accepted Submission(s): 753



Problem Description

In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now N frogs
are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is
the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of at most one frog and thus the strength of those frogs might change.

The frogs wonder the maximum possible strength after the witch finishes her job.

Input

First line contains an integer T,
which indicates the number of test cases.

Every test case only contains a string with length N,
including only 0 (representing

a black frog) and 1 (representing
a white frog).

⋅ 1≤T≤50.

⋅ for
60% data, 1≤N≤1000.

⋅ for
100% data, 1≤N≤105.

⋅ the
string only contains 0 and 1.

Output

For every test case, you should output "Case #x: y",where x indicates
the case number and counts from 1 and y is
the answer.

Sample Input

2
000011
0101


Sample Output

Case #1: 26
Case #2: 10


Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)

题意:给你一个01串,几个相同字符相连的串代表这个串长度平方的数,让你最多改变一个字符,求得数的最大和

思路:用一个数组记录,相同字符相连的串的长度,然后分别对其两种情况取最大值。

1.当前字符与两边的字符都不同,改变当前与原来的sum取最大值

2.是让前一个联通快长还是让后一个长,分别取最大值。

ps:尴尬啊,这样的连通快的题目应该做出来的啊,但是没想出来,看的队友的代码才会写了。

/*

题意:给你一个01串,几个相同字符相连的串代表这个串长度平方的数,让你最多改变一个字符,求得数的最大和
思路:用一个数组记录,相同字符相连的串的长度,然后分别对其两种情况取最大值。
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<map>
using namespace std;

typedef long long ll;
const int N = 100005;
char str
;
ll num
;
int main()
{
int t;
cin >> t;
for(int ca = 1;ca <= t;ca++)
{
scanf("%s",str);
printf("Case #%d: ",ca);
int len = strlen(str);
memset(num,0,sizeof(num));
char pre = str[0];
int cnt = 1,index = 1;
for(int i = 1;i < len;i++)
{
if(str[i] == pre)
cnt++;
else
{
pre = str[i];
num[index++] = cnt;
cnt = 1;
}
}
num[index] = cnt;
ll sum = 0;
for(int i = 1;i <= index;i++)
sum += num[i]*num[i];
ll maxn = sum;
for(int i = 1;i <= index;i++)
{
if(num[i] == 1)//左右两边与当前不同
{
ll temp = sum;
temp -= num[i-1]*num[i-1] + num[i]*num[i] + num[i+1]*num[i+1];
temp += (num[i-1]+num[i]+num[i+1]) * (num[i-1]+num[i]+num[i+1]);
maxn = max(maxn,temp);
}
else//与一边相同
{
ll temp1 = sum,temp2 = sum;
temp1 -= num[i-1]*num[i-1] + num[i]*num[i];
temp1 += (num[i-1]+1)*(num[i-1]+1) + (num[i]-1)*(num[i]-1);
maxn = max(maxn,temp1);

temp2 -= num[i]*num[i] + num[i+1]*num[i+1];
temp2 += (num[i]-1)*(num[i]-1) + (num[i+1]+1)*(num[i+1]+1);
maxn = max(maxn,temp2);
}
}

printf("%lld\n",maxn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: